rhel7安装python3

  • 时间:
  • 浏览:0
  • 来源:uu快3IOS下载_uu快3app下载_和值

yum install python36

6,机会使用pip一段话,简历pip3的软连接。

2,后来使用which python 查看下python的可执行文件的位置。

安装过程中突然出现 那末编译的情況 ,提示:no acceptable C compiler found in $PATH

转载

4,在/usr/bin/下创建软连接

至此,一台服务器上默认的版本是python3 ,一并python2页所处了,里能正常使用yum来进行安装所需的软件了。

 tar -zxvf Python-3.5.1.tgz  解压

 cd Python-3.5.1

(二)查看并备份python2相关信息

1,使用python -V 里能查看默认的版本信息。

2,去python官网下载稳定版(https://www.python.org/ftp/python/3.6.4/Python-3.6.4.tar.xz)

使用过程中,突然出现 方向键和删除键乱码的情況 ,这是机会默认只安装了readline模块而那末安装readline-devel模块,很多若果安塞进即可:yum install readline-devel,安装后再重新安塞进python3. 使用正常

./configure

make && make install        进入python目录,安装 

(三)法子一:安装配置python3

1,安装相关的包yum install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel readline-devel tk-devel gcc make

安装完成,输入python,突然出现 的是python2.7,这是机会RHEL自带python2.7,输入python3就里能了

3,可执行文件在/usr/bin/目录下,查看有关python的文件,ll /usr/bin/python*。通过查看里能得知python默认指向的是python2.7

提示那末编译器环境,安装gcc就里能了:yum install gcc -y

(一)简述

刚安装的centos7.4版本默认是安装Python2.7,机会许多命令时需使用的意味着着,比如yum等,使用的是2.7.5版本的,机会现在很多库包括django时需 使用Python3,

后来,有那我的需求:yum使用python2.7版本,django和许多的使用默认的python3版本。

wget https://www.python.org/ftp/python/3.5.1/Python-3.5.1.tgz  下载

3,安装python3

重要:通过查看里能得知python默认指向的是python2.7,机会还那末安装python3,里能先备份python文件,等python3安装好了后再创建软连接即可

4,备份默认python2.7版本

[root@localhost bin]# mv /usr/bin/python /usr/bin/python.bak

完成前一天,就里能使用 easy_install 命令安装 django

命令:

5,配置正常使用yum,使yum使用python2.7版本,后来会报错的。

5.1,修改/usr/bin/yum文件把#! /usr/bin/python修改为#! /usr/bin/python2